Mobage Unity SDK ( Android ) 1.4.11 以降の変更点

Mobage Unity SDK (Android) 1.4.11 以降では、依存ライブラリのバージョンが以下のように更新になりました。

ライブラリバージョン
android-support-v4rev.22 or later
google play servicesver.7.5.0(rev.25) or later

Mobage Unity SDK (Android) を Android Studio で Import した場合 buld.grade 内の記述が "compile 'com.android.support:support-v4:18.+'" なる可能性があります。 Mobage Unity SDK (Android) 1.4.11 以降を利用する場合は "compile 'com.android.support:support-v4:22.+'" に変更してください。

依存ライブラリのバージョンの更新に伴い、AndroidManifest.xml の変更が必要となります。
以下を参考に AndroidManifest.xml の変更を行ってください。

AndroidManifest.xml の更新

permission

変更前
変更後

receiver

変更前
変更後

更新履歴

  • 2016/09/30
    • 新規作成

 

 

PREVIOUS

プログラミングガイド

NEXT

【重要】Android ゲームポイント対応について